summaryrefslogtreecommitdiffstats
path: root/testing/gmock/Makefile.am
diff options
context:
space:
mode:
authorevan@chromium.org <evan@chromium.org@0039d316-1c4b-4281-b951-d872f2087c98>2010-03-25 17:03:47 +0000
committerevan@chromium.org <evan@chromium.org@0039d316-1c4b-4281-b951-d872f2087c98>2010-03-25 17:03:47 +0000
commit762217321f240970b7a7dc404470caedbf43cd5e (patch)
treeb0b66383100d57a8272e4b622580dff16b5007ee /testing/gmock/Makefile.am
parent7ee7e191bb9f5419b6f6fd9036e6bcdc77d5cc0b (diff)
downloadchromium_src-762217321f240970b7a7dc404470caedbf43cd5e.zip
chromium_src-762217321f240970b7a7dc404470caedbf43cd5e.tar.gz
chromium_src-762217321f240970b7a7dc404470caedbf43cd5e.tar.bz2
Update to current gtest/gmock.
Synced in new gmock, twiddled DEPS for new gtest, updated README. BUG=34160 Review URL: http://codereview.chromium.org/1151006 git-svn-id: svn://svn.chromium.org/chrome/trunk/src@42625 0039d316-1c4b-4281-b951-d872f2087c98
Diffstat (limited to 'testing/gmock/Makefile.am')
-rw-r--r--testing/gmock/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/gmock/Makefile.am b/testing/gmock/Makefile.am
index c10d81c..30941d4f 100644
--- a/testing/gmock/Makefile.am
+++ b/testing/gmock/Makefile.am
@@ -1,3 +1,5 @@
+# Automake file
+
# Nonstandard package files for distribution.
EXTRA_DIST =
@@ -16,6 +18,12 @@ DISTCLEANFILES = scripts/gmock-config
# directories.
AM_CPPFLAGS = $(GTEST_CPPFLAGS) -I$(srcdir)/include
+# Modifies compiler and linker flags for pthreads compatibility.
+if HAVE_PTHREADS
+ AM_CXXFLAGS = @PTHREAD_CFLAGS@ -DGTEST_HAS_PTHREAD=1
+ AM_LIBS = @PTHREAD_LIBS@
+endif
+
# Build rules for libraries.
lib_LTLIBRARIES = lib/libgmock.la lib/libgmock_main.la