summaryrefslogtreecommitdiffstats
path: root/testing/gmock/Makefile.am
diff options
context:
space:
mode:
authorajwong@chromium.org <ajwong@chromium.org@0039d316-1c4b-4281-b951-d872f2087c98>2009-06-22 18:32:21 +0000
committerajwong@chromium.org <ajwong@chromium.org@0039d316-1c4b-4281-b951-d872f2087c98>2009-06-22 18:32:21 +0000
commit22015c33fe44a1cc36596e0b6de37a48dc13b131 (patch)
tree643966e3ad01ab48b4f1d0ab48793261c68cee02 /testing/gmock/Makefile.am
parentad764d54ec391e95e4ea239aa8eed548ce45cb61 (diff)
downloadchromium_src-22015c33fe44a1cc36596e0b6de37a48dc13b131.zip
chromium_src-22015c33fe44a1cc36596e0b6de37a48dc13b131.tar.gz
chromium_src-22015c33fe44a1cc36596e0b6de37a48dc13b131.tar.bz2
Upgrade gtest to r267 and gmock to r173.
This is step1 into removing the boost + tr1 dependency in windows. It also includes a hack to avoid brining in tr1/functional on gcc, which will move us closer to enabling -fno-rtti. This CL has passed the try servers. I've also tried compiling gmock, gmock_main, base, base_unittests, and webcore modules in vs2008 express editions. Review URL: http://codereview.chromium.org/140003 git-svn-id: svn://svn.chromium.org/chrome/trunk/src@18923 0039d316-1c4b-4281-b951-d872f2087c98
Diffstat (limited to 'testing/gmock/Makefile.am')
-rw-r--r--testing/gmock/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/gmock/Makefile.am b/testing/gmock/Makefile.am
index 7a821a0..196b927 100644
--- a/testing/gmock/Makefile.am
+++ b/testing/gmock/Makefile.am
@@ -135,6 +135,28 @@ check_PROGRAMS += test/gmock_test
test_gmock_test_SOURCES = test/gmock_test.cc
test_gmock_test_LDADD = $(GTEST_LIBS) lib/libgmock_main.la
+# A sanity test for verifying that Google Mock works when RTTI is
+# disabled. We pick gmock-spec-builders_test.cc as it exercises all
+# components of Google Mock.
+TESTS += test/gmock_no_rtti_test
+check_PROGRAMS += test/gmock_no_rtti_test
+test_gmock_no_rtti_test_SOURCES = test/gmock-spec-builders_test.cc \
+ src/gmock-all.cc
+test_gmock_no_rtti_test_CXXFLAGS = $(AM_CXXFLAGS) -fno-rtti -DGTEST_HAS_RTTI=0
+test_gmock_no_rtti_test_LDADD = $(GTEST_LIBS)
+
+# A sanity test for verifying that Google Mock works with Google
+# Test's TR1 tuple implementation. We pick
+# gmock-spec-builders_test.cc as it exercises all components of Google
+# Mock.
+TESTS += test/gmock_use_own_tuple_test
+check_PROGRAMS += test/gmock_use_own_tuple_test
+test_gmock_use_own_tuple_test_SOURCES = test/gmock-spec-builders_test.cc \
+ src/gmock-all.cc
+test_gmock_use_own_tuple_test_CXXFLAGS = \
+ $(AM_CXXFLAGS) -DGTEST_USE_OWN_TR1_TUPLE=1
+test_gmock_use_own_tuple_test_LDADD = $(GTEST_LIBS)
+
# The following tests depend on the presence of a Python installation and are
# keyed off of it. We only add them to the TESTS variable when a Python
# interpreter is available. TODO(chandlerc@google.com): While we currently only