summaryrefslogtreecommitdiffstats
path: root/o3d/installer/linux/debian_i386/rules
diff options
context:
space:
mode:
Diffstat (limited to 'o3d/installer/linux/debian_i386/rules')
-rwxr-xr-xo3d/installer/linux/debian_i386/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/o3d/installer/linux/debian_i386/rules b/o3d/installer/linux/debian_i386/rules
new file mode 100755
index 0000000..2bd95e0
--- /dev/null
+++ b/o3d/installer/linux/debian_i386/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+# Needed for dpkg-shlibdeps to be able to find the libraries we ship with so as
+# to properly calculate our shared library dependencies.
+export LD_LIBRARY_PATH=$(shell echo $$LD_LIBRARY_PATH:$$PWD)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+# For the 32-bit package, shlibdeps may not be able to find the three dependent
+# libraries because they aren't included in our package and we don't list them
+# as a build dependency (because we can't, since on a 64-bit system that would
+# be resolved with the 64-bit packages). So, we suppress errors for this case.
+DEB_DH_SHLIBDEPS_ARGS_ALL = -- --ignore-missing-info