summaryrefslogtreecommitdiffstats
path: root/third_party/libxslt/SConscript
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/libxslt/SConscript')
-rw-r--r--third_party/libxslt/SConscript262
1 files changed, 131 insertions, 131 deletions
diff --git a/third_party/libxslt/SConscript b/third_party/libxslt/SConscript
index dc44477..dbf2c91 100644
--- a/third_party/libxslt/SConscript
+++ b/third_party/libxslt/SConscript
@@ -1,131 +1,131 @@
-# Copyright 2008, Google Inc.
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# * Redistributions in binary form must reproduce the above
-# copyright notice, this list of conditions and the following disclaimer
-# in the documentation and/or other materials provided with the
-# distribution.
-# * Neither the name of Google Inc. nor the names of its
-# contributors may be used to endorse or promote products derived from
-# this software without specific prior written permission.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-Import('env')
-
-env = env.Clone()
-
-env.Prepend(
- CPPPATH = [
- '$LIBXML_DIR/scons/include',
- '$LIBXML_DIR/include',
- '$ICU38_DIR/public/common',
- '$ICU38_DIR/public/18n',
- '$ZLIB_DIR',
- 'scons',
- '.',
- '../',
- ],
-)
-
-env.Append(
- CPPDEFINES = [
- 'U_STATIC_IMPLEMENTATION',
- 'LIBXML_STATIC',
- 'LIBXSLT_STATIC',
- ],
-)
-
-if env['PLATFORM'] == 'win32':
- env.Append(
- CCFLAGS = [
- '/TC',
- '/wd4800',
- ],
- )
-
-
-input_files = [
- 'libxslt/attributes.c',
- 'libxslt/attrvt.c',
- 'libxslt/documents.c',
- 'libxslt/extensions.c',
- 'libxslt/extra.c',
- 'libxslt/functions.c',
- 'libxslt/imports.c',
- 'libxslt/keys.c',
- 'libxslt/namespaces.c',
- 'libxslt/numbers.c',
- 'libxslt/pattern.c',
- 'libxslt/preproc.c',
- 'libxslt/security.c',
- 'libxslt/templates.c',
- 'libxslt/transform.c',
- 'libxslt/variables.c',
- 'libxslt/xslt.c',
- 'libxslt/xsltutils.c',
-]
-
-env.ChromeStaticLibrary('libxslt', input_files)
-
-
-if env['PLATFORM'] == 'win32':
- config_files = [
- # The configure.js script must be first in this list; the
- # env.Command() call below executes the first list element.
-
- 'win32/configure.js',
- 'win32/Makefile.msvc',
-
- 'config.h.in',
- 'configure.in',
- 'libexslt.pc.in',
- 'libxslt.pc.in',
- 'libxslt.spec.in',
- 'xslt-config.in',
- 'xsltConf.sh.in',
-
- 'libexslt/exsltconfig.h.in',
-
- 'libxslt/xsltconfig.h.in',
- 'libxslt/xsltwin32config.h.in',
- 'libxslt/win32config.h',
- ]
-
- copied_sources = []
- for cf in config_files:
- result = env.Command('scons/' + cf, cf, Copy('$TARGET', '$SOURCE'))
- copied_sources.extend(result)
-
- env.Command(['scons/config.h'],
- copied_sources,
- 'cd ${SOURCE.dir} && $CSCRIPT ${SOURCE.file} $CONFIG_OPTIONS',
- CONFIG_OPTIONS='compiler=msvc')
-elif env['PLATFORM'] == 'posix':
- config_files = [
- 'config.h',
- 'xslt-config',
- 'libexslt/exsltconfig.h',
- 'libxslt/xsltconfig.h',
- 'libxslt/xsltwin32config.h',
- ]
- for cf in config_files:
- result = env.Command('scons/' + cf, 'linux/' + cf,
- Copy('$TARGET', '$SOURCE'))
-
+# Copyright 2008, Google Inc.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above
+# copyright notice, this list of conditions and the following disclaimer
+# in the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Google Inc. nor the names of its
+# contributors may be used to endorse or promote products derived from
+# this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+Import('env')
+
+env = env.Clone()
+
+env.Prepend(
+ CPPPATH = [
+ '$LIBXML_DIR/scons/include',
+ '$LIBXML_DIR/include',
+ '$ICU38_DIR/public/common',
+ '$ICU38_DIR/public/18n',
+ '$ZLIB_DIR',
+ 'scons',
+ '.',
+ '../',
+ ],
+)
+
+env.Append(
+ CPPDEFINES = [
+ 'U_STATIC_IMPLEMENTATION',
+ 'LIBXML_STATIC',
+ 'LIBXSLT_STATIC',
+ ],
+)
+
+if env['PLATFORM'] == 'win32':
+ env.Append(
+ CCFLAGS = [
+ '/TC',
+ '/wd4800',
+ ],
+ )
+
+
+input_files = [
+ 'libxslt/attributes.c',
+ 'libxslt/attrvt.c',
+ 'libxslt/documents.c',
+ 'libxslt/extensions.c',
+ 'libxslt/extra.c',
+ 'libxslt/functions.c',
+ 'libxslt/imports.c',
+ 'libxslt/keys.c',
+ 'libxslt/namespaces.c',
+ 'libxslt/numbers.c',
+ 'libxslt/pattern.c',
+ 'libxslt/preproc.c',
+ 'libxslt/security.c',
+ 'libxslt/templates.c',
+ 'libxslt/transform.c',
+ 'libxslt/variables.c',
+ 'libxslt/xslt.c',
+ 'libxslt/xsltutils.c',
+]
+
+env.ChromeStaticLibrary('libxslt', input_files)
+
+
+if env['PLATFORM'] == 'win32':
+ config_files = [
+ # The configure.js script must be first in this list; the
+ # env.Command() call below executes the first list element.
+
+ 'win32/configure.js',
+ 'win32/Makefile.msvc',
+
+ 'config.h.in',
+ 'configure.in',
+ 'libexslt.pc.in',
+ 'libxslt.pc.in',
+ 'libxslt.spec.in',
+ 'xslt-config.in',
+ 'xsltConf.sh.in',
+
+ 'libexslt/exsltconfig.h.in',
+
+ 'libxslt/xsltconfig.h.in',
+ 'libxslt/xsltwin32config.h.in',
+ 'libxslt/win32config.h',
+ ]
+
+ copied_sources = []
+ for cf in config_files:
+ result = env.Command('scons/' + cf, cf, Copy('$TARGET', '$SOURCE'))
+ copied_sources.extend(result)
+
+ env.Command(['scons/config.h'],
+ copied_sources,
+ 'cd ${SOURCE.dir} && $CSCRIPT ${SOURCE.file} $CONFIG_OPTIONS',
+ CONFIG_OPTIONS='compiler=msvc')
+elif env['PLATFORM'] == 'posix':
+ config_files = [
+ 'config.h',
+ 'xslt-config',
+ 'libexslt/exsltconfig.h',
+ 'libxslt/xsltconfig.h',
+ 'libxslt/xsltwin32config.h',
+ ]
+ for cf in config_files:
+ result = env.Command('scons/' + cf, 'linux/' + cf,
+ Copy('$TARGET', '$SOURCE'))
+