summaryrefslogtreecommitdiffstats
path: root/src/crypto/chacha/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/chacha/CMakeLists.txt')
-rw-r--r--src/crypto/chacha/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/crypto/chacha/CMakeLists.txt b/src/crypto/chacha/CMakeLists.txt
new file mode 100644
index 0000000..6c3f87e
--- /dev/null
+++ b/src/crypto/chacha/CMakeLists.txt
@@ -0,0 +1,20 @@
+include_directories(. .. ../../include)
+
+if (${ARCH} STREQUAL "arm")
+ set(
+ CHACHA_ARCH_SOURCES
+
+ chacha_vec_arm.S
+ )
+endif()
+
+add_library(
+ chacha
+
+ OBJECT
+
+ chacha_generic.c
+ chacha_vec.c
+
+ ${CHACHA_ARCH_SOURCES}
+)