summaryrefslogtreecommitdiffstats
path: root/src/crypto/dsa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/dsa/CMakeLists.txt')
-rw-r--r--src/crypto/dsa/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/crypto/dsa/CMakeLists.txt b/src/crypto/dsa/CMakeLists.txt
new file mode 100644
index 0000000..fbc053e
--- /dev/null
+++ b/src/crypto/dsa/CMakeLists.txt
@@ -0,0 +1,20 @@
+include_directories(. .. ../../include)
+
+add_library(
+ dsa
+
+ OBJECT
+
+ dsa.c
+ dsa_impl.c
+ dsa_asn1.c
+ dsa_error.c
+)
+
+add_executable(
+ dsa_test
+
+ dsa_test.c
+)
+
+target_link_libraries(dsa_test crypto)