summaryrefslogtreecommitdiffstats
path: root/src/crypto/ec/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/ec/CMakeLists.txt')
-rw-r--r--src/crypto/ec/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/crypto/ec/CMakeLists.txt b/src/crypto/ec/CMakeLists.txt
index 9808cd5..4749484 100644
--- a/src/crypto/ec/CMakeLists.txt
+++ b/src/crypto/ec/CMakeLists.txt
@@ -1,5 +1,13 @@
include_directories(../../include)
+if (${ARCH} STREQUAL "x86_64")
+ set(
+ EC_ARCH_SOURCES
+
+ p256-x86_64-asm.${ASM_EXT}
+ )
+endif()
+
add_library(
ec
@@ -12,11 +20,16 @@ add_library(
oct.c
p224-64.c
p256-64.c
- util-64.c
+ p256-x86_64.c
simple.c
+ util-64.c
wnaf.c
+
+ ${EC_ARCH_SOURCES}
)
+perlasm(p256-x86_64-asm.${ASM_EXT} asm/p256-x86_64-asm.pl)
+
add_executable(
example_mul