summaryrefslogtreecommitdiffstats
path: root/src/crypto/err/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/err/CMakeLists.txt')
-rw-r--r--src/crypto/err/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/crypto/err/CMakeLists.txt b/src/crypto/err/CMakeLists.txt
new file mode 100644
index 0000000..53dccea
--- /dev/null
+++ b/src/crypto/err/CMakeLists.txt
@@ -0,0 +1,18 @@
+include_directories(. .. ../../include)
+
+add_library(
+ err
+
+ OBJECT
+
+ err.c
+ err_impl.c
+)
+
+add_executable(
+ err_test
+
+ err_test.c
+)
+
+target_link_libraries(err_test crypto)