summaryrefslogtreecommitdiffstats
path: root/src/crypto/poly1305/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/poly1305/CMakeLists.txt')
-rw-r--r--src/crypto/poly1305/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/crypto/poly1305/CMakeLists.txt b/src/crypto/poly1305/CMakeLists.txt
new file mode 100644
index 0000000..bb0c1e4
--- /dev/null
+++ b/src/crypto/poly1305/CMakeLists.txt
@@ -0,0 +1,21 @@
+include_directories(. .. ../../include)
+
+if (${ARCH} STREQUAL "arm")
+ set(
+ POLY1305_ARCH_SOURCES
+
+ poly1305_arm_asm.S
+ )
+endif()
+
+add_library(
+ poly1305
+
+ OBJECT
+
+ poly1305.c
+ poly1305_arm.c
+ poly1305_vec.c
+
+ ${POLY1305_ARCH_SOURCES}
+)