summaryrefslogtreecommitdiffstats
path: root/src/crypto/rsa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/rsa/CMakeLists.txt')
-rw-r--r--src/crypto/rsa/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/crypto/rsa/CMakeLists.txt b/src/crypto/rsa/CMakeLists.txt
new file mode 100644
index 0000000..b3d8fa4
--- /dev/null
+++ b/src/crypto/rsa/CMakeLists.txt
@@ -0,0 +1,22 @@
+include_directories(. .. ../../include)
+
+add_library(
+ rsa
+
+ OBJECT
+
+ rsa.c
+ rsa_impl.c
+ blinding.c
+ padding.c
+ rsa_asn1.c
+ rsa_error.c
+)
+
+add_executable(
+ rsa_test
+
+ rsa_test.c
+)
+
+target_link_libraries(rsa_test crypto)