summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2014-04-25 12:31:11 +0900
committerDaiki Ueno <ueno@gnu.org>2014-04-25 12:42:12 +0900
commit41a2f19194e11830064583a7d7b5f86743b941ad (patch)
tree79c21e3caba7843ccd4318b964c6f3064ce8c2a1 /Makefile.am
parent7880eb189254a73b2ad5aa836768b09d529311fa (diff)
downloadexternal_gettext-41a2f19194e11830064583a7d7b5f86743b941ad.zip
external_gettext-41a2f19194e11830064583a7d7b5f86743b941ad.tar.gz
external_gettext-41a2f19194e11830064583a7d7b5f86743b941ad.tar.bz2
build: Turn update-po.sh into a Makefile rule
Suggested by Andreas Stricker in: <https://lists.gnu.org/archive/html/bug-gettext/2014-04/msg00020.html>. * configure.ac (maintainer-update-po): New recursive rule. * update-po.sh: Remove. * autogen.sh: Don't mention update-po.sh. * Makefile.am (maintainer-update-po-local): New rule. * gettext-runtime/Makefile.am (maintainer-update-po): New rule. * gettext-runtime/man/Makefile.am (update-man1): Remove; add explicit dependency on the executable to each .1 rule. * gettext-tools/man/Makefile.am (update-man1): Remove; add explicit dependency on the executable to each .1 rule.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b094a7..22fe614 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = gnulib-local gettext-runtime gettext-tools
EXTRA_DIST = \
- DEPENDENCIES PACKAGING HACKING ChangeLog.0 autogen.sh update-po.sh \
+ DEPENDENCIES PACKAGING HACKING ChangeLog.0 autogen.sh \
build-aux/ac-help.sed build-aux/moopp \
m4/fixautomake.m4 m4/woe32-dll.m4 \
m4/libtool.m4
@@ -127,3 +127,7 @@ $(top_srcdir)/.version:
echo $(VERSION) > $@-t && mv $@-t $@
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
+
+# PO files update.
+
+maintainer-update-po-local: $(top_builddir)/config.status