summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2003-03-03 18:53:40 +0000
committerBruno Haible <bruno@clisp.org>2009-06-23 12:10:15 +0200
commit3fe0ffb294a39802c32016060cda4b2beed4a6a3 (patch)
tree20759de97979ebd0e3c7e25f9fd542cf6d3bfe5d /configure.ac
parent6a14da3ebd3e08524f49bd570b3ff66a64acdb7f (diff)
downloadexternal_gettext-3fe0ffb294a39802c32016060cda4b2beed4a6a3.zip
external_gettext-3fe0ffb294a39802c32016060cda4b2beed4a6a3.tar.gz
external_gettext-3fe0ffb294a39802c32016060cda4b2beed4a6a3.tar.bz2
Fix the --help output of the toplevel configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b189e52..f1d220d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,18 @@ dnl Checks for library functions.
AC_CONFIG_SUBDIRS(autoconf-lib-link gettext-runtime gettext-tools)
+dnl Ensure that "configure --help" lists all the command line options that
+dnl are usable with the subdir configures. Really AC_CONFIG_SUBDIRS should
+dnl do it by itself.
+dnl System types:
+AC_CANONICAL_HOST
+dnl Optional Features: AC_ARG_ENABLE calls
+dnl Optional Packages: AC_ARG_WITH calls
+dnl Some influential environment variables: AC_ARG_VAR calls
+esyscmd([cd autoconf-lib-link && autoconf --trace=AC_ARG_ENABLE:'$n([$1],[$2])' --trace=AC_ARG_WITH:'$n([$1],[$2])' --trace=AC_ARG_VAR:'$n($@)'])
+esyscmd([cd gettext-runtime && autoconf --trace=AC_ARG_ENABLE:'$n([$1],[$2])' --trace=AC_ARG_WITH:'$n([$1],[$2])' --trace=AC_ARG_VAR:'$n($@)'])
+esyscmd([cd gettext-tools && autoconf --trace=AC_ARG_ENABLE:'$n([$1],[$2])' --trace=AC_ARG_WITH:'$n([$1],[$2])' --trace=AC_ARG_VAR:'$n($@)'])
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT