summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-12-14 18:11:38 +0100
committerDaiki Ueno <ueno@gnu.org>2013-05-30 13:07:31 +0900
commit417f0080823ae17d0f258ec08f3810cd0274e021 (patch)
tree71022b82f8c10636ebd85e1d6d85384c91a2e9f3 /configure.ac
parent3533f6cc3521ead6ed20740e5256c4837786a35c (diff)
downloadexternal_gettext-417f0080823ae17d0f258ec08f3810cd0274e021.zip
external_gettext-417f0080823ae17d0f258ec08f3810cd0274e021.tar.gz
external_gettext-417f0080823ae17d0f258ec08f3810cd0274e021.tar.bz2
build: enable parallel tests harness from Automake
This way, we'll be able to run test cases in parallel (useful on multicore systems), and output from test cases will be saved in log files, which should simplify debugging and bug reporting. * configure.ac (AM_INIT_AUTOMAKE): Add 'parallel-tests' option. Require Automake 1.11.1 or later, so that the 'parallel-tests' will be certainly available. (AC_INIT): Require Autoconf 2.62 or later; that is the minimal version supported by Automake 1.11.1 or later. * gettext-runtime/configure.ac: Likewise. * gettext-tools/configure.ac: Likewise. * autogen.sh: Update version number requirement for Autoconf. * gettext-tools/tests/Makefile.am (TESTS_ENVIRONMENT): Remove trailing '$(SHELL)'. With the parallel-tests harness, this is no longer the correct way to define a custom test runner for the test scripts; to do so, we have to ... (LOG_COMPILER): ... define this to $(SHELL). Copyright-paperwork-exempt: yes Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7c8d2c0..fcff9e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,13 +16,13 @@ dnl along with this program. If not, see <http://www.gnu.org/licenses/>.
dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ([2.59])
+AC_PREREQ([2.62])
AC_INIT
AC_CONFIG_SRCDIR([gettext-tools/src/msgfmt.c])
AC_CONFIG_AUX_DIR([build-aux])
. $srcdir/version.sh
gl_INIT_PACKAGE([gettext], [$VERSION_NUMBER])
-AM_INIT_AUTOMAKE([silent-rules])
+AM_INIT_AUTOMAKE([1.11.1 silent-rules parallel-tests])
dnl Override automake's tar command used for creating distributions.
am__tar='${AMTAR} chof - --owner=root --group=root "$$tardir"'