summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2002-11-11 20:56:11 +0000
committerBruno Haible <bruno@clisp.org>2009-06-23 12:08:51 +0200
commit6f29a54cc5be4acf9c49f55f8a7253858318eac4 (patch)
treeacb972112402de56ec11f2d55d4cd094df2046f8 /configure.in
parent9a6ffd42db758e703b6b550c171d148e82680389 (diff)
downloadexternal_gettext-6f29a54cc5be4acf9c49f55f8a7253858318eac4.zip
external_gettext-6f29a54cc5be4acf9c49f55f8a7253858318eac4.tar.gz
external_gettext-6f29a54cc5be4acf9c49f55f8a7253858318eac4.tar.bz2
Require a C++ compiler with namespaces support.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 76d51e3..ca07c27 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.52)
AC_INIT
AC_CONFIG_SRCDIR(src/msgfmt.c)
-AM_INIT_AUTOMAKE(gettext, 0.11.6-pre1)
+AM_INIT_AUTOMAKE(gettext, 0.11.6-pre2)
RELEASE_DATE=2002-08-06 dnl in "date +%Y-%m-%d" format
AM_CONFIG_HEADER(config.h)
@@ -206,6 +206,27 @@ if test "$CXX" != ":"; then
AC_MSG_RESULT($ac_cv_prog_cxx_works)
if test $ac_cv_prog_cxx_works = no; then
CXX=:
+ else
+ dnl Test for namespaces. Both libasprintf and tests/lang-c++ need it.
+ dnl We don't bother supporting pre-ANSI-C++ compilers.
+ AC_MSG_CHECKING([whether the C++ compiler supports namespaces])
+ AC_LANG_PUSH(C++)
+ cat <<EOF > conftest.$ac_ext
+#include <iostream.h>
+namespace test { using namespace std; }
+int main () { return 0; }
+EOF
+ if AC_TRY_EVAL([ac_link]) && test -s conftest$ac_exeext; then
+ gt_cv_prog_cxx_namespaces=yes
+ else
+ gt_cv_prog_cxx_namespaces=no
+ fi
+ rm -fr conftest*
+ AC_LANG_POP(C++)
+ AC_MSG_RESULT($gt_cv_prog_cxx_namespaces)
+ if test $gt_cv_prog_cxx_namespaces = no; then
+ CXX=:
+ fi
fi
fi