summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2001-01-17 17:45:22 +0000
committerBruno Haible <bruno@clisp.org>2001-01-17 17:45:22 +0000
commita7a991ef5dcd4db939e5a90957a431544d1864d8 (patch)
treec4b90b94b9ce88e7b9bb2b97568c1a8909240368 /configure.in
parent67053507debd8316db3c810227ab721d4eb15e38 (diff)
downloadexternal_gettext-a7a991ef5dcd4db939e5a90957a431544d1864d8.zip
external_gettext-a7a991ef5dcd4db939e5a90957a431544d1864d8.tar.gz
external_gettext-a7a991ef5dcd4db939e5a90957a431544d1864d8.tar.bz2
Since gettext is doesn't translate any more in the C locale, we must use
setlocale() in the testsuite. But since SunOS 4 and other old systems have no other locales than the C locale, we must implement a fake setlocale() ourselves.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0ee90f1..1d46931 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.12)
-AC_REVISION($Revision: 1.5 $)
+AC_REVISION($Revision: 1.6 $)
AC_INIT(src/msgfmt.c)
AM_INIT_AUTOMAKE(gettext, 0.10.36)
AM_CONFIG_HEADER(config.h)
@@ -22,7 +22,7 @@ dnl Checks for libraries.
dnl Checks for header files.
AC_HEADER_STDC
-AC_HAVE_HEADERS(limits.h malloc.h string.h unistd.h values.h)
+AC_CHECK_HEADERS(limits.h malloc.h string.h unistd.h values.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -54,6 +54,8 @@ fi
AM_FUNC_ERROR_AT_LINE
+gt_SETLOCALE
+
dnl These are the only lines required to internationalize the package.
dnl (OK, not quite, the AC_OUTPUT has also some parts.)
AM_GNU_GETTEXT