summaryrefslogtreecommitdiffstats
path: root/gettext-runtime/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2003-02-14 20:47:18 +0000
committerBruno Haible <bruno@clisp.org>2009-06-23 12:10:03 +0200
commite802ee88941f5a15fb699a4d5ec269edaa1c9165 (patch)
treeea8c01cf445425bd060701e0bae6c82f0d77be06 /gettext-runtime/Makefile.am
parentee143b1138e14bbb28b30865b9d2609d8d52bfcc (diff)
downloadexternal_gettext-e802ee88941f5a15fb699a4d5ec269edaa1c9165.zip
external_gettext-e802ee88941f5a15fb699a4d5ec269edaa1c9165.tar.gz
external_gettext-e802ee88941f5a15fb699a4d5ec269edaa1c9165.tar.bz2
New infrastructure for gettext-runtime directory.
Diffstat (limited to 'gettext-runtime/Makefile.am')
-rw-r--r--gettext-runtime/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/gettext-runtime/Makefile.am b/gettext-runtime/Makefile.am
new file mode 100644
index 0000000..a5517f6
--- /dev/null
+++ b/gettext-runtime/Makefile.am
@@ -0,0 +1,48 @@
+## Makefile for the gettext-runtime directory of GNU gettext
+## Copyright (C) 1995-1999, 2000-2003 Free Software Foundation, Inc.
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
+ACLOCAL_AMFLAGS = -I m4 -I ../gettext-tools/m4 -I ../autoconf-lib-link/m4 -I ../config/m4
+
+MAKEINFO = env LANG= LANGUAGE= @MAKEINFO@
+
+SUBDIRS = doc intl intl-java lib @SUBDIR_libasprintf@ src po man m4
+DIST_SUBDIRS = doc intl intl-java lib libasprintf src po man m4
+
+EXTRA_DIST = BUGS
+
+
+# Documentation tags not known to automake.
+
+ps:
+ cd doc && $(MAKE) ps
+
+pdf:
+ cd doc && $(MAKE) pdf
+
+html:
+ cd doc && $(MAKE) html
+
+
+all-local: ABOUT-NLS
+
+ABOUT-NLS: $(srcdir)/doc/nls.texi $(srcdir)/doc/matrix.texi
+ rm -f $(srcdir)/ABOUT-NLS \
+ && $(MAKEINFO) --output=$(srcdir)/ABOUT-NLS --no-header \
+ -I $(srcdir)/doc --no-validate nls.texi