summaryrefslogtreecommitdiffstats
path: root/gettext-runtime/configure.ac
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2005-08-03 11:20:41 +0000
committerBruno Haible <bruno@clisp.org>2009-06-23 12:12:46 +0200
commit39c573c98576b8952268311f627cec7562b1fe95 (patch)
tree9cd21c221af73754292e7093ea1a115fb11cb703 /gettext-runtime/configure.ac
parent6e0ad5eccb5e18754270277fcbb5d1ee903b419e (diff)
downloadexternal_gettext-39c573c98576b8952268311f627cec7562b1fe95.zip
external_gettext-39c573c98576b8952268311f627cec7562b1fe95.tar.gz
external_gettext-39c573c98576b8952268311f627cec7562b1fe95.tar.bz2
New glocale library.
Diffstat (limited to 'gettext-runtime/configure.ac')
-rw-r--r--gettext-runtime/configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/gettext-runtime/configure.ac b/gettext-runtime/configure.ac
index 2492eee..f195404 100644
--- a/gettext-runtime/configure.ac
+++ b/gettext-runtime/configure.ac
@@ -149,7 +149,18 @@ if test "$CXX" = ":"; then
fi
AC_SUBST(SUBDIR_libasprintf)
-AC_CONFIG_SUBDIRS(libasprintf)
+dnl Determine whether to build glocale.
+AC_ARG_ENABLE(libglocale,
+ [ --disable-libglocale do not build libglocale],
+ [if test "$enableval" != no; then
+ SUBDIR_glocale=glocale
+ else
+ SUBDIR_glocale=
+ fi
+ ], SUBDIR_glocale=glocale)
+AC_SUBST(SUBDIR_glocale)
+
+AC_CONFIG_SUBDIRS(libasprintf glocale)
AC_CONFIG_FILES([Makefile])