summaryrefslogtreecommitdiffstats
path: root/gettext-runtime/libasprintf/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2003-04-01 00:54:46 +0000
committerBruno Haible <bruno@clisp.org>2009-06-23 12:10:19 +0200
commit6a570c60b014562bd473a22f061caad63ed8f561 (patch)
treef2baf658a17dd4127e044d74c139859186200607 /gettext-runtime/libasprintf/Makefile.am
parent2784ad9f09ef6d0db9cc917ed984a5e13df7703f (diff)
downloadexternal_gettext-6a570c60b014562bd473a22f061caad63ed8f561.zip
external_gettext-6a570c60b014562bd473a22f061caad63ed8f561.tar.gz
external_gettext-6a570c60b014562bd473a22f061caad63ed8f561.tar.bz2
Support for VMS.
Diffstat (limited to 'gettext-runtime/libasprintf/Makefile.am')
-rw-r--r--gettext-runtime/libasprintf/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/gettext-runtime/libasprintf/Makefile.am b/gettext-runtime/libasprintf/Makefile.am
index 40d21ed..04e486a 100644
--- a/gettext-runtime/libasprintf/Makefile.am
+++ b/gettext-runtime/libasprintf/Makefile.am
@@ -179,6 +179,32 @@ uninstall-html:
EXTRA_DIST += texi2html autosprintf.html
+# VMS support.
+
+config.h.vms: config.h.in
+ (sed -e 's/#undef HAVE_ALLOCA$$/#define HAVE_ALLOCA 1/' \
+ -e 's/#undef HAVE_DLFCN_H$$/#define HAVE_DLFCN_H 1/' \
+ -e 's/#undef HAVE_INTMAX_T$$/#define HAVE_INTMAX_T 1/' \
+ -e 's/#undef HAVE_INTTYPES_H$$/#define HAVE_INTTYPES_H 1/' \
+ -e 's/#undef HAVE_INTTYPES_H_WITH_UINTMAX$$/#define HAVE_INTTYPES_H_WITH_UINTMAX 1/' \
+ -e 's/#undef HAVE_LONG_DOUBLE$$/#define HAVE_LONG_DOUBLE 1/' \
+ -e 's/#undef HAVE_LONG_LONG$$/#define HAVE_LONG_LONG 1/' \
+ -e 's/#undef HAVE_MEMORY_H$$/#define HAVE_MEMORY_H 1/' \
+ -e 's/#undef HAVE_PTRDIFF_T$$/#define HAVE_PTRDIFF_T 1/' \
+ -e 's/#undef HAVE_STDLIB_H$$/#define HAVE_STDLIB_H 1/' \
+ -e 's/#undef HAVE_STRINGS_H$$/#define HAVE_STRINGS_H 1/' \
+ -e 's/#undef HAVE_STRING_H$$/#define HAVE_STRING_H 1/' \
+ -e 's/#undef HAVE_SYS_STAT_H$$/#define HAVE_SYS_STAT_H 1/' \
+ -e 's/#undef HAVE_SYS_TYPES_H$$/#define HAVE_SYS_TYPES_H 1/' \
+ -e 's/#undef HAVE_UNISTD_H$$/#define HAVE_UNISTD_H 1/' \
+ -e 's/#undef HAVE_WCHAR_T$$/#define HAVE_WCHAR_T 1/' \
+ -e 's/#undef HAVE_WINT_T$$/#define HAVE_WINT_T 1/' \
+ -e 's/#undef STDC_HEADERS$$/#define STDC_HEADERS 1/' \
+ < $<; echo; echo '#define alloca __ALLOCA'; echo '#include <vms_jackets.h>') > $@
+
+EXTRA_DIST += Makefile.vms config.h.vms
+
+
# Woe32 support.
config.h.msvc: config.h.in