summaryrefslogtreecommitdiffstats
path: root/gettext-tools/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2014-04-25 12:31:11 +0900
committerDaiki Ueno <ueno@gnu.org>2014-04-25 12:42:12 +0900
commit41a2f19194e11830064583a7d7b5f86743b941ad (patch)
tree79c21e3caba7843ccd4318b964c6f3064ce8c2a1 /gettext-tools/Makefile.am
parent7880eb189254a73b2ad5aa836768b09d529311fa (diff)
downloadexternal_gettext-41a2f19194e11830064583a7d7b5f86743b941ad.zip
external_gettext-41a2f19194e11830064583a7d7b5f86743b941ad.tar.gz
external_gettext-41a2f19194e11830064583a7d7b5f86743b941ad.tar.bz2
build: Turn update-po.sh into a Makefile rule
Suggested by Andreas Stricker in: <https://lists.gnu.org/archive/html/bug-gettext/2014-04/msg00020.html>. * configure.ac (maintainer-update-po): New recursive rule. * update-po.sh: Remove. * autogen.sh: Don't mention update-po.sh. * Makefile.am (maintainer-update-po-local): New rule. * gettext-runtime/Makefile.am (maintainer-update-po): New rule. * gettext-runtime/man/Makefile.am (update-man1): Remove; add explicit dependency on the executable to each .1 rule. * gettext-tools/man/Makefile.am (update-man1): Remove; add explicit dependency on the executable to each .1 rule.
Diffstat (limited to 'gettext-tools/Makefile.am')
-rw-r--r--gettext-tools/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/gettext-tools/Makefile.am b/gettext-tools/Makefile.am
index e93ab1f..3eb3238 100644
--- a/gettext-tools/Makefile.am
+++ b/gettext-tools/Makefile.am
@@ -58,3 +58,9 @@ EXTRA_DIST += README.woe32
# Cygwin support.
EXTRA_DIST += woe32dll/export.h
+
+maintainer-update-po: $(top_builddir)/config.status
+ $(SHELL) ./config.status --recheck
+ $(SHELL) ./config.status po/Makefile.in po-directories
+ cd po && $(MAKE) update-po
+ cd examples && $(MAKE) maintainer-update-po