summaryrefslogtreecommitdiffstats
path: root/gettext-tools/gnulib-lib/Makefile.am
diff options
context:
space:
mode:
authorKO Myung-Hun <komh78@gmail.com>2016-01-12 11:35:50 +0900
committerDaiki Ueno <ueno@gnu.org>2016-01-20 11:38:26 +0900
commit62d6e88d34695f76ca7de556d77810a2efd96dd6 (patch)
tree719d58e27a3cc35635fc65183304e290171d81df /gettext-tools/gnulib-lib/Makefile.am
parent429e302f5215b78f65e833a87d76de71ca94696b (diff)
downloadexternal_gettext-62d6e88d34695f76ca7de556d77810a2efd96dd6.zip
external_gettext-62d6e88d34695f76ca7de556d77810a2efd96dd6.tar.gz
external_gettext-62d6e88d34695f76ca7de556d77810a2efd96dd6.tar.bz2
gettext-tools: Use a short name for DLLs on OS/2
OS/2 does not support a DLL name longer than 8 characters. * gettext-tools/configure.ac (OS2): Define on OS/2. * gettext-tools/gnulib-lib/Makefile.am (libgettextlib_la_LDFLAGS): Set a DLL name to gtlib on OS/2. * gettext-tools/libgettextpo/Makefile.am (libgettextpo_la_LDFLAGS): Set a DLL name to gtpo on OS/2. * gettext-tools/src/Makefile.am (libgettextsrc_la_LDFLAGS): Set a DLL name to gtsrc on OS/2.
Diffstat (limited to 'gettext-tools/gnulib-lib/Makefile.am')
-rw-r--r--gettext-tools/gnulib-lib/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/gettext-tools/gnulib-lib/Makefile.am b/gettext-tools/gnulib-lib/Makefile.am
index 1da342f..25c9cc1 100644
--- a/gettext-tools/gnulib-lib/Makefile.am
+++ b/gettext-tools/gnulib-lib/Makefile.am
@@ -61,6 +61,11 @@ include Makefile.gnulib
# Which classes to export from the shared library.
MOOPPFLAGS += --dllexport=styled_ostream
+# OS/2 does not support a DLL name longer than 8 characters.
+if OS2
+libgettextlib_la_LDFLAGS += -os2dllname gtlib
+endif
+
# Linking with C++ libraries is needed _only_ on mingw and Cygwin.
if !WOE32DLL
libgettextlib_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \