summaryrefslogtreecommitdiffstats
path: root/gettext-tools/src/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2015-10-05 17:18:41 +0900
committerDaiki Ueno <ueno@gnu.org>2015-12-04 13:02:40 +0900
commitb3c2a5a242c36fbbaa0c5b17f975d6c638598a23 (patch)
tree454e3065e789cb88e669ced7b1db0d0645ae1099 /gettext-tools/src/Makefile.am
parenta2e9e118689b26ea088b581b2b8d739bee6852fc (diff)
downloadexternal_gettext-b3c2a5a242c36fbbaa0c5b17f975d6c638598a23.zip
external_gettext-b3c2a5a242c36fbbaa0c5b17f975d6c638598a23.tar.gz
external_gettext-b3c2a5a242c36fbbaa0c5b17f975d6c638598a23.tar.bz2
msgfmt: Support XML file merging
* gettext-tools/src/Makefile.am (noinst_HEADERS): Add write-xml.h. (msgfmt_SOURCES): Add write-xml.c. * gettext-tools/src/its.c (its_merge_context_merge_node): New function. (its_merge_context_merge): New function. (its_merge_context_alloc): New function. (its_merge_context_write): New function. (its_merge_context_free): New function. * gettext-tools/src/its.h (its_merge_context_ty): New type. * gettext-tools/src/msgfmt.c: Include "its.h", "locating-rule.h", and "write-xml.h". (SIZEOF): New macro. (xml_mode, xml_locale_name, xml_template_name, xml_base_directory, xml_language, xml_its_rules): New variable. (long_options): Add --language and --xml. (main): Handle new options. (usage): Document new options. (msgfmt_xml_bulk): New function. * gettext-tools/src/write-xml.c: New file. * gettext-tools/src/write-xml.h: New file. * gettext-tools/doc/gettext.texi: Mention XML file merging use-case. * gettext-tools/doc/msgfmt.texi: Mention --xml option. * gettext-tools/tests/msgfmt-xml-1: New file. * gettext-tools/tests/msgfmt-xml-2: New file. * gettext-tools/tests/Makefile.am (TESTS): Add new tests.
Diffstat (limited to 'gettext-tools/src/Makefile.am')
-rw-r--r--gettext-tools/src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gettext-tools/src/Makefile.am b/gettext-tools/src/Makefile.am
index 27cc7af..f3dab4c 100644
--- a/gettext-tools/src/Makefile.am
+++ b/gettext-tools/src/Makefile.am
@@ -51,6 +51,7 @@ read-resources.h write-resources.h \
read-tcl.h write-tcl.h \
write-qt.h \
read-desktop.h write-desktop.h \
+write-xml.h \
po-time.h plural-table.h lang-table.h format.h filters.h \
xgettext.h x-c.h x-po.h x-sh.h x-python.h x-lisp.h x-elisp.h x-librep.h \
x-scheme.h x-smalltalk.h x-java.h x-properties.h x-csharp.h x-awk.h x-ycp.h \
@@ -164,7 +165,8 @@ msgcmp_SOURCES += msgl-fsearch.c
msgfmt_SOURCES = msgfmt.c
msgfmt_SOURCES += \
write-mo.c write-java.c write-csharp.c write-resources.c write-tcl.c \
- write-qt.c write-desktop.c ../../gettext-runtime/intl/hash-string.c
+ write-qt.c write-desktop.c write-xml.c \
+ ../../gettext-runtime/intl/hash-string.c
if !WOE32DLL
msgmerge_SOURCES = msgmerge.c
else