summaryrefslogtreecommitdiffstats
path: root/gettext-tools/tests/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-12-14 18:11:38 +0100
committerDaiki Ueno <ueno@gnu.org>2013-05-30 13:07:31 +0900
commit417f0080823ae17d0f258ec08f3810cd0274e021 (patch)
tree71022b82f8c10636ebd85e1d6d85384c91a2e9f3 /gettext-tools/tests/Makefile.am
parent3533f6cc3521ead6ed20740e5256c4837786a35c (diff)
downloadexternal_gettext-417f0080823ae17d0f258ec08f3810cd0274e021.zip
external_gettext-417f0080823ae17d0f258ec08f3810cd0274e021.tar.gz
external_gettext-417f0080823ae17d0f258ec08f3810cd0274e021.tar.bz2
build: enable parallel tests harness from Automake
This way, we'll be able to run test cases in parallel (useful on multicore systems), and output from test cases will be saved in log files, which should simplify debugging and bug reporting. * configure.ac (AM_INIT_AUTOMAKE): Add 'parallel-tests' option. Require Automake 1.11.1 or later, so that the 'parallel-tests' will be certainly available. (AC_INIT): Require Autoconf 2.62 or later; that is the minimal version supported by Automake 1.11.1 or later. * gettext-runtime/configure.ac: Likewise. * gettext-tools/configure.ac: Likewise. * autogen.sh: Update version number requirement for Autoconf. * gettext-tools/tests/Makefile.am (TESTS_ENVIRONMENT): Remove trailing '$(SHELL)'. With the parallel-tests harness, this is no longer the correct way to define a custom test runner for the test scripts; to do so, we have to ... (LOG_COMPILER): ... define this to $(SHELL). Copyright-paperwork-exempt: yes Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'gettext-tools/tests/Makefile.am')
-rw-r--r--gettext-tools/tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/gettext-tools/tests/Makefile.am b/gettext-tools/tests/Makefile.am
index f2c4848..423804e 100644
--- a/gettext-tools/tests/Makefile.am
+++ b/gettext-tools/tests/Makefile.am
@@ -195,8 +195,9 @@ TESTS_ENVIRONMENT = top_srcdir=$(top_srcdir) \
LOCALE_FR_UTF8='@LOCALE_FR_UTF8@' \
LOCALE_JA='@LOCALE_JA@' \
host_os='@host_os@' \
- CONFIG_SHELL='$(SHELL)' \
- $(SHELL)
+ CONFIG_SHELL='$(SHELL)'
+
+LOG_COMPILER = $(SHELL)
# Update the expected test results.
update-expected: xg-c-1.ok.po