summaryrefslogtreecommitdiffstats
path: root/gettext-tools/tests/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2005-01-29 15:21:42 +0000
committerBruno Haible <bruno@clisp.org>2009-06-23 12:12:08 +0200
commit7606d5591d17428161b1a73ebcc6c4fbec9a44d9 (patch)
tree720ee781610db6e6e9ddbbf78978f2a63ecddc12 /gettext-tools/tests/Makefile.am
parent1be6fe6509d5559c9836c1b6992f0a57e1ec3b1c (diff)
downloadexternal_gettext-7606d5591d17428161b1a73ebcc6c4fbec9a44d9.zip
external_gettext-7606d5591d17428161b1a73ebcc6c4fbec9a44d9.tar.gz
external_gettext-7606d5591d17428161b1a73ebcc6c4fbec9a44d9.tar.bz2
Fix link error when building statically on MacOS X.
Diffstat (limited to 'gettext-tools/tests/Makefile.am')
-rw-r--r--gettext-tools/tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gettext-tools/tests/Makefile.am b/gettext-tools/tests/Makefile.am
index a57272c..44454c4 100644
--- a/gettext-tools/tests/Makefile.am
+++ b/gettext-tools/tests/Makefile.am
@@ -165,8 +165,10 @@ AM_CPPFLAGS = \
-I../lib -I$(top_srcdir)/lib \
-I../intl
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+# INTL_MACOSX_LIBS is needed because the programs depend on libintl.la
+# but libtool doesn't put -Wl,-framework options into .la files.
LDADD = $(LDADD_@USE_INCLUDED_LIBINTL@)
-LDADD_yes = ../intl/libintl.la
+LDADD_yes = ../intl/libintl.la @INTL_MACOSX_LIBS@
LDADD_no = ../intl/libgnuintl.la @LTLIBINTL@
noinst_PROGRAMS = tstgettext tstngettext testlocale cake fc3 fc4 fc5
tstgettext_SOURCES = tstgettext.c setlocale.c