summaryrefslogtreecommitdiffstats
path: root/gettext-tools/tests/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2003-12-07 12:42:16 +0000
committerBruno Haible <bruno@clisp.org>2009-06-23 12:11:27 +0200
commitc625209bdd0c1294535212107507c8933c5b7320 (patch)
tree4ff9c09e1bf94f7717422e5d2c1ba90cabcceed9 /gettext-tools/tests/Makefile.am
parentac768f92ce1f97e0b765c7e4e54839da8728aa1b (diff)
downloadexternal_gettext-c625209bdd0c1294535212107507c8933c5b7320.zip
external_gettext-c625209bdd0c1294535212107507c8933c5b7320.tar.gz
external_gettext-c625209bdd0c1294535212107507c8933c5b7320.tar.bz2
Test whether the locale is usable. If not, skip the tests.
Diffstat (limited to 'gettext-tools/tests/Makefile.am')
-rw-r--r--gettext-tools/tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gettext-tools/tests/Makefile.am b/gettext-tools/tests/Makefile.am
index b1c0f6a..899d29b 100644
--- a/gettext-tools/tests/Makefile.am
+++ b/gettext-tools/tests/Makefile.am
@@ -155,13 +155,14 @@ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
LDADD = $(LDADD_@USE_INCLUDED_LIBINTL@)
LDADD_yes = ../intl/libintl.la
LDADD_no = ../intl/libgnuintl.la @LTLIBINTL@
-noinst_PROGRAMS = tstgettext tstngettext cake fc3 fc4
+noinst_PROGRAMS = tstgettext tstngettext testlocale cake fc3 fc4
tstgettext_SOURCES = tstgettext.c setlocale.c
tstgettext_CFLAGS = -DINSTALLDIR=\".\"
tstgettext_LDADD = ../lib/libgettextlib.la $(LDADD)
tstngettext_SOURCES = tstngettext.c setlocale.c
tstngettext_CFLAGS = -DINSTALLDIR=\".\"
tstngettext_LDADD = ../lib/libgettextlib.la $(LDADD)
+testlocale_SOURCES = testlocale.c
cake_SOURCES = plural-1-prg.c setlocale.c
cake_LDADD = ../lib/libgettextlib.la $(LDADD)
fc3_SOURCES = format-c-3-prg.c setlocale.c