summaryrefslogtreecommitdiffstats
path: root/gettext-tools/tests/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2013-08-30 17:23:50 +0900
committerDaiki Ueno <ueno@gnu.org>2013-08-30 17:23:50 +0900
commitd9479ba454161926511014c99706b1a4edd4d010 (patch)
treef3639359335630563da08fac586d92a1cc79da99 /gettext-tools/tests/Makefile.am
parented2d6c181253e47d247a488bcb902c5980a19e10 (diff)
downloadexternal_gettext-d9479ba454161926511014c99706b1a4edd4d010.zip
external_gettext-d9479ba454161926511014c99706b1a4edd4d010.tar.gz
external_gettext-d9479ba454161926511014c99706b1a4edd4d010.tar.bz2
Don't add 'gnulib-lib' to include path when compiling libgettextpo tests.
Diffstat (limited to 'gettext-tools/tests/Makefile.am')
-rw-r--r--gettext-tools/tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/gettext-tools/tests/Makefile.am b/gettext-tools/tests/Makefile.am
index c03c606..e1e0df2 100644
--- a/gettext-tools/tests/Makefile.am
+++ b/gettext-tools/tests/Makefile.am
@@ -235,7 +235,12 @@ fc4_LDADD = ../gnulib-lib/libgettextlib.la $(LDADD)
fc5_SOURCES = format-c-5-prg.c
fc5_LDADD = ../gnulib-lib/libgettextlib.la $(LDADD)
gettextpo_1_prg_SOURCES = gettextpo-1-prg.c
-gettextpo_1_prg_CPPFLAGS = -I../libgettextpo -I$(top_srcdir)/libgettextpo $(AM_CPPFLAGS)
+# Don't add 'gnulib-lib' to the include path here. Some header files
+# there may interfere with the ones in 'libgettextpo'.
+gettextpo_1_prg_CPPFLAGS = \
+ -I.. \
+ -I../libgettextpo -I$(top_srcdir)/libgettextpo \
+ -I../intl
# Don't add more libraries here. This test must check whether libgettextpo is
# self contained.
gettextpo_1_prg_LDADD = ../libgettextpo/libgettextpo.la $(LDADD)