summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2001-07-02 12:58:44 +0000
committerBruno Haible <bruno@clisp.org>2001-07-02 12:58:44 +0000
commit8d9da1d5b82fd0fb061986a4fec6daf78f0ee788 (patch)
treea9b3fc2492833a0415219da59a8e03166e2cd546 /lib/Makefile.am
parent2071088926c348fbfad8cd0a562e63d7eb636440 (diff)
downloadexternal_gettext-8d9da1d5b82fd0fb061986a4fec6daf78f0ee788.zip
external_gettext-8d9da1d5b82fd0fb061986a4fec6daf78f0ee788.tar.gz
external_gettext-8d9da1d5b82fd0fb061986a4fec6daf78f0ee788.tar.bz2
Use 'bool' where appropriate.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 84ac17f..abaae75 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -24,6 +24,7 @@ noinst_LIBRARIES = libnlsut.a
EXTRA_DIST = alloca.c config.charset error.c getline.c memset.c memmove.c \
printf-prs.c ref-add.sin ref-del.sin stpcpy.c stpncpy.c strcasecmp.c \
strcspn.c strncasecmp.c strstr.c strtol.c strtoul.c vasprintf.c \
+stdbool.h.in \
gen-lbrkprop.c 3level.h
libnlsut_a_SOURCES = basename.c c-ctype.c concatpath.c findprog.c fstrcmp.c \
@@ -42,6 +43,12 @@ DEFS = -DLIBDIR=\"$(libdir)\" @DEFS@
INCLUDES = -I. -I$(srcdir) -I.. -I../intl
+all-local: @STDBOOL_H@
+stdbool.h: stdbool.h.in
+ cp $(srcdir)/stdbool.h.in stdbool.h
+MOSTLYCLEANFILES = @STDBOOL_H@
+
+
# The following is needed in order to install a simple file in $(libdir)
# which is shared with other installed packages. We use a list of referencing
# packages so that "make uninstall" will remove the file if and only if it