summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2001-03-06 15:09:27 +0000
committerBruno Haible <bruno@clisp.org>2001-03-06 15:09:27 +0000
commit8f746ca065b2d9c1d77012cf0d7fbc26542da620 (patch)
treeb79042bd33d9a939c207112dab8d3cbb663713d0 /lib/Makefile.am
parent1cdf3237843b59a8c72cbd3f2f2e2118e3573277 (diff)
downloadexternal_gettext-8f746ca065b2d9c1d77012cf0d7fbc26542da620.zip
external_gettext-8f746ca065b2d9c1d77012cf0d7fbc26542da620.tar.gz
external_gettext-8f746ca065b2d9c1d77012cf0d7fbc26542da620.tar.bz2
Fix the --width option to not split multibyte characters, and respect the
wcwidth of the characters.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am69
1 files changed, 60 insertions, 9 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 3cab0b0..9059a5a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,5 @@
## Makefile for the support lib subdirectory of the GNU NLS Utilities
-## Copyright (C) 1995, 1996, 1997 Free Software Foundation, Inc.
+## Copyright (C) 1995-1998, 2000, 2001 Free Software Foundation, Inc.
##
## This program is free software; you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
@@ -21,16 +21,67 @@ AUTOMAKE_OPTIONS = 1.2 gnits
noinst_LIBRARIES = libnlsut.a
-EXTRA_DIST = alloca.c error.c getline.c memset.c memmove.c \
-printf-prs.c stpcpy.c stpncpy.c strcasecmp.c strcspn.c strncasecmp.c \
-strstr.c strtol.c strtoul.c vasprintf.c
+EXTRA_DIST = alloca.c config.charset error.c getline.c memset.c memmove.c \
+printf-prs.c ref-add.sin ref-del.sin stpcpy.c stpncpy.c strcasecmp.c \
+strcspn.c strncasecmp.c strstr.c strtol.c strtoul.c vasprintf.c \
+gen-lbrkprop.c 3level.h
-libnlsut_a_SOURCES = basename.c fstrcmp.c getopt.c getopt1.c hash.c obstack.c \
-xgetcwd.c xmalloc.c xstrdup.c
+libnlsut_a_SOURCES = basename.c c-ctype.c fstrcmp.c getopt.c getopt1.c \
+hash.c linebreak.c localcharset.c obstack.c xgetcwd.c xmalloc.c xstrdup.c
libnlsut_a_LIBADD = @ALLOCA@ @LIBOBJS@
-noinst_HEADERS = error.h fstrcmp.h getline.h getopt.h hash.h obstack.h \
-printf-parse.h printf.h system.h pathmax.h
+noinst_HEADERS = c-ctype.h error.h fstrcmp.h getline.h getopt.h hash.h \
+lbrkprop.h linebreak.h obstack.h printf-parse.h printf.h system.h pathmax.h
-INCLUDES = -I../intl
+DEFS = -DLIBDIR=\"$(libdir)\" @DEFS@
+INCLUDES = -I. -I$(srcdir) -I.. -I../intl
+
+
+# The following is needed in order to install a simple file in $(libdir)
+# which is shared with other installed packages. We use a list of referencing
+# packages so that "make uninstall" will remove the file if and only if it
+# is not used by another installed package.
+# On systems with glibc-2.1 or newer, the file is redundant, therefore we
+# avoid installing it.
+
+all-local: charset.alias ref-add.sed ref-del.sed
+
+charset_alias = $(DESTDIR)$(libdir)/charset.alias
+charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
+install-exec-local: all-local
+ $(mkinstalldirs) $(DESTDIR)$(libdir)
+ if test -f $(charset_alias); then \
+ sed -f ref-add.sed $(charset_alias) > $(charset_tmp) ; \
+ $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
+ rm -f $(charset_tmp) ; \
+ else \
+ if test @GLIBC21@ = no; then \
+ sed -f ref-add.sed charset.alias > $(charset_tmp) ; \
+ $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
+ rm -f $(charset_tmp) ; \
+ fi ; \
+ fi
+
+uninstall-local: all-local
+ if test -f $(charset_alias); then \
+ sed -f ref-del.sed $(charset_alias) > $(charset_tmp); \
+ if grep '^# Packages using this file: $$' $(charset_tmp) \
+ > /dev/null; then \
+ rm -f $(charset_alias); \
+ else \
+ $(INSTALL_DATA) $(charset_tmp) $(charset_alias); \
+ fi; \
+ rm -f $(charset_tmp); \
+ fi
+
+charset.alias: config.charset
+ $(SHELL) $(srcdir)/config.charset '@host@' > t-$@
+ mv t-$@ $@
+
+SUFFIXES = .sed .sin
+.sin.sed:
+ sed -e '/^#/d' -e 's/@''PACKAGE''@/@PACKAGE@/g' $< > t-$@
+ mv t-$@ $@
+
+CLEANFILES = charset.alias ref-add.sed ref-del.sed