summaryrefslogtreecommitdiffstats
path: root/autoconf-lib-link/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf-lib-link/configure.ac')
-rw-r--r--autoconf-lib-link/configure.ac67
1 files changed, 67 insertions, 0 deletions
diff --git a/autoconf-lib-link/configure.ac b/autoconf-lib-link/configure.ac
new file mode 100644
index 0000000..889fbd8
--- /dev/null
+++ b/autoconf-lib-link/configure.ac
@@ -0,0 +1,67 @@
+dnl Configuration for the autoconf-lib-link directory of GNU gettext
+dnl Copyright (C) 1995-1999, 2000-2003 Free Software Foundation, Inc.
+dnl
+dnl This program is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 2, or (at your option)
+dnl any later version.
+dnl
+dnl This program is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+dnl GNU General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with this program; if not, write to the Free Software
+dnl Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.57)
+AC_INIT
+AC_CONFIG_SRCDIR(tests/rpath-1a)
+AC_CONFIG_AUX_DIR(../config)
+. $srcdir/../version.sh
+AM_INIT_AUTOMAKE(autoconf-lib-link, $VERSION_NUMBER)
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+
+dnl Check for host type.
+AC_CANONICAL_HOST
+
+dnl Checks for UNIX variants that set DEFS,
+
+dnl Checks for compiler output filename suffixes.
+AC_OBJEXT
+AC_EXEEXT
+
+dnl Check for build configuration.
+AC_LIBTOOL_WIN32_DLL
+AC_PROG_LIBTOOL
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+
+dnl Checks for library functions.
+
+dnl Checks for tests/rpathcfg.
+AC_SUBST(GCC)
+AC_SUBST(LD)
+AC_SUBST(with_gnu_ld)
+
+aclocaldir='${datadir}/aclocal'
+AC_SUBST(aclocaldir)
+
+AC_CONFIG_FILES([Makefile],
+ [FIX_MAKEFILE_DISTRIB([Makefile])])
+
+AC_CONFIG_FILES([m4/Makefile])
+
+AC_CONFIG_FILES([tests/Makefile])
+
+AC_OUTPUT