summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index c289627..71e8785 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.13)
-AC_REVISION($Revision: 1.12 $)
+AC_REVISION($Revision: 1.13 $)
AC_INIT(src/msgfmt.c)
AM_INIT_AUTOMAKE(gettext, 0.10.36)
AM_CONFIG_HEADER(config.h)
@@ -10,11 +10,22 @@ ALL_LINGUAS="da de el es fr ja ko nl nn no pl pt sl sv tr"
dnl Checks for programs.
AC_PROG_CC
-AM_PROG_LIBTOOL
-AC_ISC_POSIX
AC_PROG_INSTALL
AC_PROG_YACC
+dnl Check for host type.
+AC_CANONICAL_HOST
+
+dnl Checks for UNIX variants that set DEFS,
+AC_ISC_POSIX
+
+dnl Checks for compiler output filename suffixes.
+AC_OBJEXT
+AC_EXEEXT
+
+dnl Check for build configuration.
+AM_PROG_LIBTOOL
+
AC_DEFINE(_GNU_SOURCE, 1, [Make sure we see all GNU extensions.])
dnl Checks for libraries.