summaryrefslogtreecommitdiffstats
path: root/gettext-runtime/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gettext-runtime/Makefile.am')
-rw-r--r--gettext-runtime/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/gettext-runtime/Makefile.am b/gettext-runtime/Makefile.am
index bc0b20a..a6abaec 100644
--- a/gettext-runtime/Makefile.am
+++ b/gettext-runtime/Makefile.am
@@ -46,3 +46,40 @@ ABOUT-NLS: $(srcdir)/doc/nls.texi $(srcdir)/doc/matrix.texi
rm -f $(srcdir)/ABOUT-NLS \
&& $(MAKEINFO) --output=$(srcdir)/ABOUT-NLS --no-header \
-I $(srcdir)/doc --no-validate nls.texi
+
+
+# Woe32 support.
+
+config.h.msvc: config.h.in
+ sed -e 's/#undef ENABLE_NLS$$/#define ENABLE_NLS 1/' \
+ -e 's/#undef ENABLE_RELOCATABLE$$/#define ENABLE_RELOCATABLE 1/' \
+ -e 's/#undef HAVE_ALLOCA$$/#define HAVE_ALLOCA 1/' \
+ -e 's/#undef HAVE_ENVIRON_DECL$$/#define HAVE_ENVIRON_DECL 1/' \
+ -e 's/#undef HAVE_ERRNO_DECL$$/#define HAVE_ERRNO_DECL 1/' \
+ -e 's/#undef HAVE_GETCWD$$/#define HAVE_GETCWD 1/' \
+ -e 's/#undef HAVE_ICONV$$/#define HAVE_ICONV 1/' \
+ -e 's/#undef HAVE_LIMITS_H$$/#define HAVE_LIMITS_H 1/' \
+ -e 's/#undef HAVE_LOCALE_H$$/#define HAVE_LOCALE_H 1/' \
+ -e 's/#undef HAVE_MEMMOVE$$/#define HAVE_MEMMOVE 1/' \
+ -e 's/#undef HAVE_PUTENV$$/#define HAVE_PUTENV 1/' \
+ -e 's/#undef HAVE_SETLOCALE$$/#define HAVE_SETLOCALE 1/' \
+ -e 's/#undef HAVE_STDDEF_H$$/#define HAVE_STDDEF_H 1/' \
+ -e 's/#undef HAVE_STDLIB_H$$/#define HAVE_STDLIB_H 1/' \
+ -e 's/#undef HAVE_STRDUP$$/#define HAVE_STRDUP 1/' \
+ -e 's/#undef HAVE_STRERROR$$/#define HAVE_STRERROR 1/' \
+ -e 's/#undef HAVE_STRING_H$$/#define HAVE_STRING_H 1/' \
+ -e 's/#undef HAVE_STRTOUL$$/#define HAVE_STRTOUL 1/' \
+ -e 's/#undef HAVE_SYS_STAT_H$$/#define HAVE_SYS_STAT_H 1/' \
+ -e 's/#undef HAVE_SYS_TYPES_H$$/#define HAVE_SYS_TYPES_H 1/' \
+ -e 's/#undef HAVE_VPRINTF$$/#define HAVE_VPRINTF 1/' \
+ -e 's/#undef ICONV_CONST$$/#define ICONV_CONST const/' \
+ -e 's/#undef STACK_DIRECTION$$/#define STACK_DIRECTION -1/' \
+ -e 's/#undef STDC_HEADERS$$/#define STDC_HEADERS 1/' \
+ -e 's/#undef uintmax_t$$/#define uintmax_t unsigned long/' \
+ -e '/#undef INSTALLPREFIX$$/d' \
+ < $< > $@
+
+intl/libgnuintl.h.msvc-shared: intl/libgnuintl.h.in windows/dllexport.h
+ sed -e 's/extern \([^"]\)/extern LIBINTL_DLL_EXPORTED \1/' -e '/#define _LIBINTL_H/r windows/dllexport.h' < $< > $@
+
+EXTRA_DIST += README.woe32 Makefile.msvc config.h.msvc windows/dllexport.h windows/intl.rc