summaryrefslogtreecommitdiffstats
path: root/gettext-runtime/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gettext-runtime/configure.ac')
-rw-r--r--gettext-runtime/configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/gettext-runtime/configure.ac b/gettext-runtime/configure.ac
index 2492eee..f195404 100644
--- a/gettext-runtime/configure.ac
+++ b/gettext-runtime/configure.ac
@@ -149,7 +149,18 @@ if test "$CXX" = ":"; then
fi
AC_SUBST(SUBDIR_libasprintf)
-AC_CONFIG_SUBDIRS(libasprintf)
+dnl Determine whether to build glocale.
+AC_ARG_ENABLE(libglocale,
+ [ --disable-libglocale do not build libglocale],
+ [if test "$enableval" != no; then
+ SUBDIR_glocale=glocale
+ else
+ SUBDIR_glocale=
+ fi
+ ], SUBDIR_glocale=glocale)
+AC_SUBST(SUBDIR_glocale)
+
+AC_CONFIG_SUBDIRS(libasprintf glocale)
AC_CONFIG_FILES([Makefile])