summaryrefslogtreecommitdiffstats
path: root/gettext-tools/examples/hello-objc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gettext-tools/examples/hello-objc/Makefile.am')
-rw-r--r--gettext-tools/examples/hello-objc/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/gettext-tools/examples/hello-objc/Makefile.am b/gettext-tools/examples/hello-objc/Makefile.am
new file mode 100644
index 0000000..2fd9bef
--- /dev/null
+++ b/gettext-tools/examples/hello-objc/Makefile.am
@@ -0,0 +1,31 @@
+# Example for use of GNU gettext.
+# Copyright (C) 2003 Free Software Foundation, Inc.
+# This file is in the public domain.
+#
+# Makefile configuration - processed by automake.
+
+# General automake options.
+AUTOMAKE_OPTIONS = foreign no-dependencies
+ACLOCAL_AMFLAGS = -I m4
+
+# The list of subdirectories containing Makefiles.
+SUBDIRS = m4 po
+
+# The list of programs that are built.
+bin_PROGRAMS = hello
+
+# The source files of the 'hello' program.
+hello_SOURCES = hello.m gettext.h
+
+# Define a C macro LOCALEDIR indicating where catalogs will be installed.
+localedir = $(datadir)/locale
+DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
+# Make sure the gettext.h include file is found.
+INCLUDES = -I. -I$(srcdir)
+
+# Link time dependencies.
+LDADD = @LIBINTL@
+
+# Additional files to be distributed.
+EXTRA_DIST = autogen.sh autoclean.sh