aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@lanedo.com>2012-07-03 15:44:49 +0200
committerAleksander Morgado <aleksander@lanedo.com>2012-07-03 15:47:13 +0200
commit5520616c9d5a94f5e43e363b10b10a09dde4865c (patch)
tree140fe46b81153ef0a96a2488bf89b6560db18e43 /configure.ac
parent85b380fcb5ac42d74bede9baa9b94c31b375208e (diff)
downloadexternal_libqmi-5520616c9d5a94f5e43e363b10b10a09dde4865c.zip
external_libqmi-5520616c9d5a94f5e43e363b10b10a09dde4865c.tar.gz
external_libqmi-5520616c9d5a94f5e43e363b10b10a09dde4865c.tar.bz2
build: setup autotools
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 45 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..10110ae
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,45 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_PREREQ([2.68])
+
+AC_INIT([libqmi-glib], [0.0.1], [aleksander@gnu.org])
+AC_CONFIG_SRCDIR([config.h.in])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+
+AM_INIT_AUTOMAKE([1.11 no-define no-dist-gzip dist-xz tar-ustar -Wno-portability])
+AM_MAINTAINER_MODE([enable])
+
+dnl Support silent build rules. Disable
+dnl by either passing --disable-silent-rules to configure or passing V=1
+dnl to make
+AM_SILENT_RULES([yes])
+
+dnl Required programs
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_PROG_INSTALL
+
+dnl Initialize libtool
+LT_PREREQ([2.2])
+LT_INIT
+
+dnl General dependencies
+PKG_CHECK_MODULES(LIBQMI_GLIB,
+ glib-2.0 >= 2.22
+ gobject-2.0
+ gio-2.0)
+AC_SUBST(LIBQMI_GLIB_CFLAGS)
+AC_SUBST(LIBQMI_GLIB_LIBS)
+
+AC_CONFIG_FILES([Makefile
+ src/Makefile])
+AC_OUTPUT
+
+echo "
+ libgqmi $VERSION
+ ==============================================
+
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ Maintainer mode: ${USE_MAINTAINER_MODE}
+"