summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Gohman <gohman@apple.com>2008-10-17 01:33:43 +0000
committerDan Gohman <gohman@apple.com>2008-10-17 01:33:43 +0000
commit63f97201dc9dcebbe84d1b73113166c64212b4b8 (patch)
tree718d542a3b0cf7a6c76944afed13d26afbb6a12f /CMakeLists.txt
parent74feef261a43392bc85280f66c75fbd4e2ccf73d (diff)
downloadexternal_llvm-63f97201dc9dcebbe84d1b73113166c64212b4b8.zip
external_llvm-63f97201dc9dcebbe84d1b73113166c64212b4b8.tar.gz
external_llvm-63f97201dc9dcebbe84d1b73113166c64212b4b8.tar.bz2
Fun x86 encoding tricks: when adding an immediate value of 128,
use a SUB instruction instead of an ADD, because -128 can be encoded in an 8-bit signed immediate field, while +128 can't be. This avoids the need for a 32-bit immediate field in this case. A similar optimization applies to 64-bit adds with 0x80000000, with the 32-bit signed immediate field. To support this, teach tablegen how to handle 64-bit constants. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@57663 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3411eed..91ecf01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,6 +80,7 @@ set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )
# set(CMAKE_VERBOSE_MAKEFILE true)
add_definitions( -D__STDC_LIMIT_MACROS )
+add_definitions( -D__STDC_CONSTANT_MACROS )
if( LLVM_ON_UNIX )
add_definitions( -DLLVM_ON_UNIX )