summaryrefslogtreecommitdiffstats
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorEric Christopher <echristo@apple.com>2010-08-25 08:44:54 +0000
committerEric Christopher <echristo@apple.com>2010-08-25 08:44:54 +0000
commitb72573e5a6e44f059a841b79a7d216686ddd9660 (patch)
tree4406167192fb30423e85d6f4e9eac9cc0943287f /autoconf/configure.ac
parent61c3f9ae0624281a7feb0027b8bb87874fadbcd4 (diff)
downloadexternal_llvm-b72573e5a6e44f059a841b79a7d216686ddd9660.zip
external_llvm-b72573e5a6e44f059a841b79a7d216686ddd9660.tar.gz
external_llvm-b72573e5a6e44f059a841b79a7d216686ddd9660.tar.bz2
Remove getsect checks, the result is unused and is broken anyhow.
Fixes PR7967. Owen: You added these, any reason? git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@112041 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac20
1 files changed, 0 insertions, 20 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 8a42d32..0271386 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -1269,9 +1269,6 @@ fi
dnl Try to find Darwin specific crash reporting library.
AC_CHECK_HEADERS([CrashReporterClient.h])
-dnl Try to find Darwin specific linker-section library.
-AC_CHECK_HEADERS([mach-o/getsect.h])
-
dnl===-----------------------------------------------------------------------===
dnl===
dnl=== SECTION 7: Check for types and structures
@@ -1351,23 +1348,6 @@ AC_LINK_IFELSE(
AC_DEFINE(LLVM_MULTITHREADED, 0, Build multithreading support into LLVM)
AC_MSG_WARN([LLVM will be built thread-unsafe because atomic builtins are missing]))
-dnl Check for Darwin-specific getsect().
-AC_MSG_CHECKING(for getsect())
-AC_COMPILE_IFELSE(
- AC_LANG_SOURCE(
- [[#include <mach-o/getsect.h>
- int main() {
- unsigned long p;
- return (int)getsect("__DATA","__pass_info", &p);
- }
- ]]),
- AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_GETSECT, 1, Have Darwin getsect() support),
- AC_MSG_RESULT(no)
- AC_DEFINE(HAVE_GETSECT, 1, Have Darwin getsect() support)
-)
-
-
dnl===-----------------------------------------------------------------------===
dnl===
dnl=== SECTION 9: Additional checks, variables, etc.