summaryrefslogtreecommitdiffstats
path: root/lib/Analysis/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Trick <atrick@apple.com>2011-06-04 01:16:30 +0000
committerAndrew Trick <atrick@apple.com>2011-06-04 01:16:30 +0000
commit9e76422b963a65f243fdbee0abed61068b82dd98 (patch)
tree3523e779d5f1822d95cadc48768982873855c67a /lib/Analysis/CMakeLists.txt
parentc122c625ce018e33f25ba35150bed10183ae2b40 (diff)
downloadexternal_llvm-9e76422b963a65f243fdbee0abed61068b82dd98.zip
external_llvm-9e76422b963a65f243fdbee0abed61068b82dd98.tar.gz
external_llvm-9e76422b963a65f243fdbee0abed61068b82dd98.tar.bz2
New BranchProbabilityInfo analysis. Patch by Jakub Staszak!
BranchProbabilityInfo provides an interface for IR passes to query the likelihood that control follows a CFG edge. This patch provides an initial implementation of static branch predication that will populate BranchProbabilityInfo for branches with no external profile information using very simple heuristics. It currently isn't hooked up to any external profile data, so static prediction does all the work. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@132613 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Analysis/CMakeLists.txt')
-rw-r--r--lib/Analysis/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Analysis/CMakeLists.txt b/lib/Analysis/CMakeLists.txt
index 6be5617..1a975bf 100644
--- a/lib/Analysis/CMakeLists.txt
+++ b/lib/Analysis/CMakeLists.txt
@@ -6,6 +6,7 @@ add_llvm_library(LLVMAnalysis
AliasSetTracker.cpp
Analysis.cpp
BasicAliasAnalysis.cpp
+ BranchProbabilityInfo.cpp
CFGPrinter.cpp
CaptureTracking.cpp
ConstantFolding.cpp