summaryrefslogtreecommitdiffstats
path: root/lib/Bitcode/Reader/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2013-01-19 18:19:39 +0000
committerChris Lattner <sabre@nondot.org>2013-01-19 18:19:39 +0000
commit312c7d9dc126e90ca1f40d30ba9a3ba22ade35c4 (patch)
treebe03f55cf3871ebf25b14176c963837731b44fc5 /lib/Bitcode/Reader/CMakeLists.txt
parent1af132dcf3c9fd87ac8ad0c103e74ef3f8a0bae6 (diff)
downloadexternal_llvm-312c7d9dc126e90ca1f40d30ba9a3ba22ade35c4.zip
external_llvm-312c7d9dc126e90ca1f40d30ba9a3ba22ade35c4.tar.gz
external_llvm-312c7d9dc126e90ca1f40d30ba9a3ba22ade35c4.tar.bz2
BitstreamReader hasn't aged well. It's been hacked on by various people and
has past the point of making sense. Lets tidy things up: first step, moving a ton of big functions out of line. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@172904 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Bitcode/Reader/CMakeLists.txt')
-rw-r--r--lib/Bitcode/Reader/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Bitcode/Reader/CMakeLists.txt b/lib/Bitcode/Reader/CMakeLists.txt
index dfe7e10..f614c9f 100644
--- a/lib/Bitcode/Reader/CMakeLists.txt
+++ b/lib/Bitcode/Reader/CMakeLists.txt
@@ -1,6 +1,7 @@
add_llvm_library(LLVMBitReader
BitReader.cpp
BitcodeReader.cpp
+ BitstreamReader.cpp
)
add_dependencies(LLVMBitReader intrinsics_gen)