summaryrefslogtreecommitdiffstats
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-02-20 02:55:27 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-02-20 02:55:27 +0000
commit00d78f1348a5980a276bed8f9be09ce2412a6a12 (patch)
tree81597ac6d857f5ef9bb97a2341b7cfcb0dc68318 /lib/Target/X86/CMakeLists.txt
parent7ac0199287f7ebfdb4c609b0d3fd5d7fb41d1ce8 (diff)
downloadexternal_llvm-00d78f1348a5980a276bed8f9be09ce2412a6a12.zip
external_llvm-00d78f1348a5980a276bed8f9be09ce2412a6a12.tar.gz
external_llvm-00d78f1348a5980a276bed8f9be09ce2412a6a12.tar.bz2
Use explicit add_subdirectory's for LLVM target sublibraries instead
of testing for its presence at cmake time. This way the build automatically regenerates the makefiles when a svn update brings in a new sublibrary. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@126068 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index b710040..b5fa94f 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -57,3 +57,8 @@ endif()
add_llvm_target(X86CodeGen ${sources})
+add_subdirectory(AsmParser)
+add_subdirectory(Disassembler)
+add_subdirectory(InstPrinter)
+add_subdirectory(TargetInfo)
+add_subdirectory(Utils)