summaryrefslogtreecommitdiffstats
path: root/utils/TableGen/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Gohman <gohman@apple.com>2008-11-03 17:56:27 +0000
committerDan Gohman <gohman@apple.com>2008-11-03 17:56:27 +0000
commit3a5797d94662d1e3cd52ade56bc16e159ec05838 (patch)
tree82b9ebe67d4fb60f58723b4ba4db10338a32504e /utils/TableGen/CMakeLists.txt
parenteb909ca524f89a24c9bc668aebd9204783576ff2 (diff)
downloadexternal_llvm-3a5797d94662d1e3cd52ade56bc16e159ec05838.zip
external_llvm-3a5797d94662d1e3cd52ade56bc16e159ec05838.tar.gz
external_llvm-3a5797d94662d1e3cd52ade56bc16e159ec05838.tar.bz2
Change how extended types are represented in MVTs. Instead of fiddling
bits, use a union of a SimpleValueType enum and a regular Type*. This increases the size of MVT on 64-bit hosts from 32 bits to 64 bits. In most cases, this doesn't add significant overhead. There are places in codegen that use arrays of MVTs, so these are now larger, but they're small in common cases. This eliminates restrictions on the size of integer types and vector types that can be represented in codegen. As the included testcase demonstrates, it's now possible to codegen very large add operations. There are still some complications with using very large types. PR2880 is still open so they can't be used as return values on normal targets, there are no libcalls defined for very large integers so operations like multiply and divide aren't supported. This also introduces a minimal tablgen Type library, capable of handling IntegerType and VectorType. This will allow parts of TableGen that don't depend on using SimpleValueType values to handle arbitrary integer and vector types. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@58623 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'utils/TableGen/CMakeLists.txt')
-rw-r--r--utils/TableGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/utils/TableGen/CMakeLists.txt b/utils/TableGen/CMakeLists.txt
index 8141d76..8e6a3e1 100644
--- a/utils/TableGen/CMakeLists.txt
+++ b/utils/TableGen/CMakeLists.txt
@@ -15,6 +15,7 @@ add_executable(tblgen
SubtargetEmitter.cpp
TGLexer.cpp
TGParser.cpp
+ TGValueTypes.cpp
TableGen.cpp
TableGenBackend.cpp
FastISelEmitter.cpp