summaryrefslogtreecommitdiffstats
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt14
1 files changed, 2 insertions, 12 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index f4e0331..e9399f5 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -29,7 +29,7 @@ set(sources
X86InstrInfo.cpp
X86JITInfo.cpp
X86MCAsmInfo.cpp
- X86MCCodeEmitter.cpp
+ X86MCCodeEmitter.cpp
X86MCInstLower.cpp
X86RegisterInfo.cpp
X86SelectionDAGInfo.cpp
@@ -49,14 +49,4 @@ if( CMAKE_CL_64 )
endif()
add_llvm_target(X86CodeGen ${sources})
-target_link_libraries(LLVMX86CodeGen
- LLVMAnalysis
- LLVMAsmPrinter
- LLVMCodeGen
- LLVMCore
- LLVMMC
- LLVMSelectionDAG
- LLVMTarget
- LLVMX86AsmPrinter
- LLVMX86Info
- )
+