summaryrefslogtreecommitdiffstats
path: root/src/compiler/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-01-18 10:47:13 +0200
committerEmil Velikov <emil.l.velikov@gmail.com>2016-01-26 16:08:20 +0000
commit1a882fd2ee84ae28a06cf07902dc4645d8ad4a6d (patch)
treedc85ad30ac20db8eecc658e7efcb3b0d7de898af /src/compiler/Makefile.am
parent2f86383091bde24a2a0b90a43c11a13165f8c397 (diff)
downloadexternal_mesa3d-1a882fd2ee84ae28a06cf07902dc4645d8ad4a6d.zip
external_mesa3d-1a882fd2ee84ae28a06cf07902dc4645d8ad4a6d.tar.gz
external_mesa3d-1a882fd2ee84ae28a06cf07902dc4645d8ad4a6d.tar.bz2
nir: move shader_enums.[ch] to compiler
This way one can reuse it in glsl, nir or other infrastructure without pulling nir as dependency. Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Acked-by: Matt Turner <mattst88@gmail.com> Acked-by: Jose Fonseca <jfonseca@vmware.com>
Diffstat (limited to 'src/compiler/Makefile.am')
-rw-r--r--src/compiler/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/compiler/Makefile.am b/src/compiler/Makefile.am
index 8ed8205..fd1dd4b 100644
--- a/src/compiler/Makefile.am
+++ b/src/compiler/Makefile.am
@@ -22,4 +22,25 @@
include Makefile.sources
-EXTRA_DIST = $(LIBCOMPILER_FILES)
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_srcdir)/src/mesa/ \
+ -I$(top_srcdir)/src/gallium/include \
+ -I$(top_srcdir)/src/gallium/auxiliary \
+ $(DEFINES)
+
+AM_CFLAGS = \
+ $(VISIBILITY_CFLAGS) \
+ $(MSVC2013_COMPAT_CFLAGS)
+
+AM_CXXFLAGS = \
+ $(VISIBILITY_CXXFLAGS) \
+ $(MSVC2013_COMPAT_CXXFLAGS)
+
+noinst_LTLIBRARIES = libcompiler.la
+
+libcompiler_la_SOURCES = $(LIBCOMPILER_FILES)
+
+EXTRA_DIST = SConscript