summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Rocard <kevin.rocard@intel.com>2015-04-11 23:00:47 +0200
committerEric Laurent <elaurent@google.com>2015-04-24 13:39:14 -0700
commit3067473d780e1651804c37f3475dce96e49a7e95 (patch)
tree5f84ffbb47bed171d1b1f653a3057a8ded92f736 /CMakeLists.txt
parentef1c51a552368aabbee17c2faf16348b6ee873be (diff)
downloadexternal_parameter-framework-3067473d780e1651804c37f3475dce96e49a7e95.zip
external_parameter-framework-3067473d780e1651804c37f3475dce96e49a7e95.tar.gz
external_parameter-framework-3067473d780e1651804c37f3475dce96e49a7e95.tar.bz2
Move tests inclusion in a test CMakeList
The root CMakeList was including every test directories directly, although it should be kept simple. Move the inclusions to a dedicated CMakeList in test. Signed-off-by: Kevin Rocard <kevin.rocard@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 37a9ffa..fbff0d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,11 +65,7 @@ function(set_test_env TestName)
PYTHONPATH=${CMAKE_BINARY_DIR}/bindings/python:$ENV{PYTHONPATH})
endfunction()
-add_subdirectory(test/test-platform)
-add_subdirectory(test/test-fixed-point-parameter)
-add_subdirectory(test/tokenizer)
-add_subdirectory(test/functional-tests)
-add_subdirectory(test/test-subsystem)
+add_subdirectory(test)
option(BASH_COMPLETION "Install bash completion configuration" ON)
if (BASH_COMPLETION)