summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Wagner <david.wagner@intel.com>2014-02-17 15:14:15 +0100
committerDavid Wagner <david.wagner@intel.com>2014-02-17 16:44:14 +0100
commit3fac6d8f4e0d65a02a478dd32947c74b82b1b7b5 (patch)
treeb0fb0f3fbdc1b1e262c3eb9e415bb8bb30d9432b /CMakeLists.txt
parent4ff62d67aaf128546af2b4a4ec728a1c731998d0 (diff)
downloadexternal_parameter-framework-3fac6d8f4e0d65a02a478dd32947c74b82b1b7b5.zip
external_parameter-framework-3fac6d8f4e0d65a02a478dd32947c74b82b1b7b5.tar.gz
external_parameter-framework-3fac6d8f4e0d65a02a478dd32947c74b82b1b7b5.tar.bz2
Add CMake Makefiles
1) Generate the Makefiles with "cmake"; 2) compile all targets with "make". Signed-off-by: David Wagner <david.wagner@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..283f452
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,19 @@
+# has been tested on 2.8 only - might work on older versions
+cmake_minimum_required(VERSION 2.8)
+
+# linking policy (see cmake --help-policy CMP0003)
+if(COMMAND cmake_policy)
+ cmake_policy(SET CMP0003 NEW)
+endif(COMMAND cmake_policy)
+
+project(parameter-framework)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wall -Wextra") # -Wno-unused-parameter
+
+add_subdirectory(xmlserializer)
+add_subdirectory(parameter)
+add_subdirectory(utility)
+add_subdirectory(remote-processor)
+
+add_subdirectory(remote-process)
+add_subdirectory(test/test-platform)