summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Rocard <kevin.rocard@intel.com>2015-03-06 10:36:40 +0100
committerEric Laurent <elaurent@google.com>2015-04-24 13:32:47 -0700
commit7fe36eead17ee1afb9ba26e1e4eb8613b559f71d (patch)
treeaa5c5d1c3de1ed4d3208534510f21eadffae5ce0 /CMakeLists.txt
parentfe6401ed98f5546040f29d8124046840468754fa (diff)
downloadexternal_parameter-framework-7fe36eead17ee1afb9ba26e1e4eb8613b559f71d.zip
external_parameter-framework-7fe36eead17ee1afb9ba26e1e4eb8613b559f71d.tar.gz
external_parameter-framework-7fe36eead17ee1afb9ba26e1e4eb8613b559f71d.tar.bz2
Use ctest for testing
Test were enabled with the enable_testing command. Nevertheless this method is very basic. Include CTest, as this cmake utility enables automatic build + test + coverage generation + memchek test (valgrind) + sending report in one command: ```make Experimental``` There are far more features added by this utility, see: http://www.cmake.org/Wiki/CMake/Testing_With_CTest#Dashboards Signed-off-by: Kevin Rocard <kevin.rocard@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 696e4a0..fcef282 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,7 +45,10 @@ add_subdirectory(remote-processor)
add_subdirectory(remote-process)
-enable_testing()
+include(CTest)
+# Ctest requires its configuration to be placed at the build root
+configure_file(CTestCustom.cmake ${CMAKE_BINARY_DIR} COPYONLY)
+
add_subdirectory(test/test-platform)
add_subdirectory(test/test-fixed-point-parameter)