summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Wagner <david.wagner@intel.com>2015-01-06 11:03:06 +0100
committerDavid Wagner <david.wagner@intel.com>2015-01-28 20:02:31 +0100
commit8a7cecb43ea8a3c887b3c7949ff512fadc756ae9 (patch)
tree0827b3d34e283c735cd4a7689bb89bb96f3ada1c /CMakeLists.txt
parentfaa623c40bcfba17f222b738c036cd8fdcdd3a4d (diff)
downloadexternal_parameter-framework-8a7cecb43ea8a3c887b3c7949ff512fadc756ae9.zip
external_parameter-framework-8a7cecb43ea8a3c887b3c7949ff512fadc756ae9.tar.gz
external_parameter-framework-8a7cecb43ea8a3c887b3c7949ff512fadc756ae9.tar.bz2
Introduce Python bindings
These bindings for the parameter-framework generic connector use "SWIG" to generate: - a C++ file providing a basic bridge between C++ and Python (must be compiled to a shared library named "_PyPfw.so" - the name is important) - a Python module wrapping it inside a Proxy class, re-creating the same classes as the parameter-framework generic connector. See http://www.swig.org for the full SWIG documentation. They are generated and compiled on-the-fly as part of the build process. Change-Id: If7c67f1178dcc9f438cf037246eb77bbd74b689a Signed-off-by: David Wagner <david.wagner@intel.com> Signed-off-by: Sebastien Gonzalve<sebastien.gonzalve@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c1c5cc..847d606 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,3 +51,5 @@ add_subdirectory(test/test-fixed-point-parameter)
add_subdirectory(tools/xmlGenerator)
add_subdirectory(tools/xmlValidator)
+
+add_subdirectory(bindings)