summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Rocard <kevinx.rocard@intel.com>2014-12-02 11:30:57 +0100
committerKevin Rocard <kevinx.rocard@intel.com>2014-12-10 16:45:27 +0100
commit9f8b7bd033fafa8a856382104e79b4dba4283632 (patch)
treea29c91386bdf19910c1ddf37e784632b4ae42e4e /CMakeLists.txt
parent7bae0ea65ca57317c0d4da24fe6ad8dab7ffb2f0 (diff)
downloadexternal_parameter-framework-9f8b7bd033fafa8a856382104e79b4dba4283632.zip
external_parameter-framework-9f8b7bd033fafa8a856382104e79b4dba4283632.tar.gz
external_parameter-framework-9f8b7bd033fafa8a856382104e79b4dba4283632.tar.bz2
Integrate fix point parameter test in cmake
Cmake can manage test with ctest. Running them when make test is run. Unfortunately the only automatic tests the pfw has (fix point parameter test) are not declared in cmake. Add a test target and declare the fix point parameter test in cmake. Thus a simple make test after the make install will run all tests. Signed-off-by: Kevin Rocard <kevinx.rocard@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5267e73..1c1c5cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,7 +44,10 @@ add_subdirectory(utility)
add_subdirectory(remote-processor)
add_subdirectory(remote-process)
+
+enable_testing()
add_subdirectory(test/test-platform)
+add_subdirectory(test/test-fixed-point-parameter)
add_subdirectory(tools/xmlGenerator)
add_subdirectory(tools/xmlValidator)