summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Rocard <kevin.rocard@intel.com>2015-02-16 11:16:13 +0100
committerKevin Rocard <kevin.rocard@intel.com>2015-02-17 11:19:14 +0100
commitacc6a08319a9caf91f36e3daba84f0840a28d6ee (patch)
treeeebb89c4c1c21a94b4e5e20488687275b2bd6eb3 /CMakeLists.txt
parent84709c9e1d35e54e51ece60c41ad640412b7bfca (diff)
downloadexternal_parameter-framework-acc6a08319a9caf91f36e3daba84f0840a28d6ee.zip
external_parameter-framework-acc6a08319a9caf91f36e3daba84f0840a28d6ee.tar.gz
external_parameter-framework-acc6a08319a9caf91f36e3daba84f0840a28d6ee.tar.bz2
Introduce remote-process bash completion
When working with the parameter-framework, the remote-process command is very handy. Nevertheless it has long commands and it is easy to make mistakes. Add a bash completion script to complete: - hostnames - frequently used port - commands and arguments based on the remote usage (help command) Signed-off-by: Kevin Rocard <kevin.rocard@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 847d606..696e4a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,7 @@ enable_testing()
add_subdirectory(test/test-platform)
add_subdirectory(test/test-fixed-point-parameter)
+add_subdirectory(tools/bash_completion)
add_subdirectory(tools/xmlGenerator)
add_subdirectory(tools/xmlValidator)