summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrien M <adrienx.martin@intel.com>2015-03-10 15:21:30 +0100
committerEric Laurent <elaurent@google.com>2015-04-24 13:39:12 -0700
commitec5130b950992fe79400ba66336d19169772a530 (patch)
tree0ddf66f1d680bf4be582b949d2596b7f08c8b74a /CMakeLists.txt
parent5aaddd16f2aabccf07687f1761567eb6455abe61 (diff)
downloadexternal_parameter-framework-ec5130b950992fe79400ba66336d19169772a530.zip
external_parameter-framework-ec5130b950992fe79400ba66336d19169772a530.tar.gz
external_parameter-framework-ec5130b950992fe79400ba66336d19169772a530.tar.bz2
Add functionnal tests to the pfw.
This patch adds functionnal test to the PFW. The execution of these tests needs the test-subsystem to be compiled. The tests can be launch with 'make test'. We set the environment vars in the cmake. Then we launch ACTCampaignEngine.py. Temporary files like build time conf files are placed on the build directory. Next steps : - Test-subsystem needs to be reworked (with binding python). Signed-off-by: Adrien M <adrienx.martin@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e5614a8..37a9ffa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2014, Intel Corporation
+# Copyright (c) 2014-2015, Intel Corporation
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without modification,
@@ -68,6 +68,8 @@ endfunction()
add_subdirectory(test/test-platform)
add_subdirectory(test/test-fixed-point-parameter)
add_subdirectory(test/tokenizer)
+add_subdirectory(test/functional-tests)
+add_subdirectory(test/test-subsystem)
option(BASH_COMPLETION "Install bash completion configuration" ON)
if (BASH_COMPLETION)