summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Rocard <kevin.rocard@intel.com>2015-04-11 23:03:52 +0200
committerEric Laurent <elaurent@google.com>2015-04-24 13:39:14 -0700
commitef9cc769da415e23ce00f9af07783997929f5f8b (patch)
tree90a7d5c77bfcbc0a3dab37c7d3ac26a3ba88c88a /CMakeLists.txt
parent3067473d780e1651804c37f3475dce96e49a7e95 (diff)
downloadexternal_parameter-framework-ef9cc769da415e23ce00f9af07783997929f5f8b.zip
external_parameter-framework-ef9cc769da415e23ce00f9af07783997929f5f8b.tar.gz
external_parameter-framework-ef9cc769da415e23ce00f9af07783997929f5f8b.tar.bz2
Move ctest definitions in it's own CMakeList
Ctest related files and definitions were at the source root although we try to keep it simple. Move all ctest related files and definition in a ctest directory. Signed-off-by: Kevin Rocard <kevin.rocard@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fbff0d9..6bf533c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,8 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wall -Wextra")
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
+include(ctest/CMakeLists.txt)
+
option(COVERAGE "Build with coverage support" OFF)
if(COVERAGE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
@@ -54,17 +56,6 @@ add_subdirectory(remote-processor)
add_subdirectory(remote-process)
-include(CTest)
-# Ctest requires its configuration to be placed at the build root
-configure_file(CTestCustom.cmake ${CMAKE_BINARY_DIR} COPYONLY)
-
-function(set_test_env TestName)
- set_property(TEST ${TestName} PROPERTY ENVIRONMENT
- PATH=${CMAKE_RUNTIME_OUTPUT_DIRECTORY}:$ENV{PATH}
- LD_LIBRARY_PATH=${CMAKE_LIBRARY_OUTPUT_DIRECTORY}:$ENV{LD_LIBRARY_PATH}
- PYTHONPATH=${CMAKE_BINARY_DIR}/bindings/python:$ENV{PYTHONPATH})
-endfunction()
-
add_subdirectory(test)
option(BASH_COMPLETION "Install bash completion configuration" ON)