summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMattijs Korpershoek <mattijs.korpershoek@gmail.com>2014-03-14 10:20:43 +0100
committerMattijs Korpershoek <mattijsx.korpershoek@intel.com>2014-06-25 15:56:48 +0200
commitf563b2da85bee9d7293301ea7da42a60f58ca40b (patch)
tree3408088a0061f58b93a4ff71ee63139d6e960406 /CMakeLists.txt
parentb394ed54bd2f38f0aa27c146e949c62fb842f8c9 (diff)
downloadexternal_parameter-framework-f563b2da85bee9d7293301ea7da42a60f58ca40b.zip
external_parameter-framework-f563b2da85bee9d7293301ea7da42a60f58ca40b.tar.gz
external_parameter-framework-f563b2da85bee9d7293301ea7da42a60f58ca40b.tar.bz2
XmlValidator tool
This tool can be used to validate a set of xml files against w3c schemas. It scans a directory recursively and checks for .xml files in it. For each file, it extracts the current schema file based on a convention (the corresponding schema file must have the same name as the root node) which is used in the parameter-framework. Change-Id: I27e32028e39a450ed18f86cb095348f73d59ade5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ffe6955..4bde584 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,3 +19,4 @@ add_subdirectory(remote-process)
add_subdirectory(test/test-platform)
add_subdirectory(tools/xmlGenerator)
+add_subdirectory(tools/xmlValidator)